New Error & Ultima Hosts

Topics: Help
Jun 21, 2007 at 3:35 PM
I just switched to Ultima Hosts because godaddy was not working. Its been much easier so far except when I try to register on the site I get this error:

'System.Web.Security.SqlMembershipProvider' requires a database compatible with schema version one.

How do I fix this? Can someone direct me on how to get the site working on Ultima Hosts?

Thanks in advance.
Coordinator
Jun 21, 2007 at 4:49 PM
Ask Ultima... they would probably know what that error implies. (All you have to do is send an email to support@ultimahost.net describing your problem.)
Jun 22, 2007 at 5:23 PM
Edited Jun 23, 2007 at 1:22 AM
I have finally worked out many of my errors by running the aspnet_regsql.exe on my server.

However, I am back to square one, my roles table is empty!

I am able to register as a user, however I don't know how to become admin with an empty role table.

Any help is appreciated! Excited to get this great site working.

Thanks.
Coordinator
Jun 23, 2007 at 1:59 AM
Open the ASP.NET Configuration tool in visual studio (with your correct connection string) and add the roles "Administrators", "Blogger", and "Editor". Then assign yourself those roles.