What are email settings in web.config for CSK 2.0

Topics: Help
Jun 25, 2007 at 9:34 PM
Hello.

I have the Club Starter Kit 2.0 running on discountASP.NET. I tried other isp's, but DASP was the only isp that i had zero problems with when installing the CSK.

I tested sending email from the website and get an error which is at the end of this post. I think it's because the email settings are not correct in the web.config. I need to know what to put in these sections:
<appSettings>
<add key="ClubName" value="The Girgenti Web Site" />
<add key="ClubSlogan" value="The Web Site of the Girgenti Family From Camden, NJ" />
<add key="ClubAddress" value="606 Lakeside Park, Southampton, PA 18966-4000" />
<add key="ClubCopyright" value="Copyright 2007 The Girgenti Web Site. All Rights Reserved." />
<add key="ClubURL" value="http://www.girgenti.info/" />
<add key="ClubMailServer" value="mail.club.com" />
<add key="ClubMailUsername" value="admin@club.com" />
<add key="ClubMailPassword" value="password" />
<add key="ReportContentUpdate" value="false" />
<add key="WebMaster" value="webmaster@clubsite.com" />
<add key="FCKeditor:UserFilesPath" value="~/Files/"/>
<add key="FCKeditor:BasePath" value="~/FCKeditor/editor"/>
</appSettings>

<system.net>
<mailSettings>
<smtp from="club@club.com">
<network host="localhost" port="25" password="clubpassword" userName="club@club.com" />
</smtp>
</mailSettings>
</system.net>


Do i need to sign up for an email account on DASP?

Any help would be gratefully appreciated.

Thanks,
Tony

Server Error in '/GirgentiWebSite' Application.
--------------------------------------------------------------------------------
A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.
Exception Details: System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond
Source Error:

Line 76: smtp.UseDefaultCredentials = False
Line 77: smtp.Credentials = a
Line 78: smtp.Send(msgMail)
Line 79: Response.Redirect("~/default.aspx")
Line 80: End Sub

Source File: C:\Documents and Settings\Administrator.TONYDELL\My Documents\Visual Studio 2005\WebSites\GirgentiWebSite\Admin\Email.aspx.vb Line: 78
Coordinator
Jun 26, 2007 at 12:10 AM
Yea... you need an email account from somewhere. It won't send without a valid SMTP server.
Jun 26, 2007 at 1:08 AM

z2bass wrote:
Yea... you need an email account from somewhere. It won't send without a valid SMTP server.


>>you need an email account from somewhere<<

So, does the email account have to be from the SMTP server?


>> It won't send without a valid SMTP server<<

According to discountASP.NET, 'network host="localhost"' is what should be there if i am using their server. Is 'network host' considered the SMTP server?

Thanks,
Tony
Coordinator
Jun 26, 2007 at 3:30 AM
I would just in the SMTP server address... it is probably better that way.

You need to be authenticated, which means you need an email address and password with them.
Jun 26, 2007 at 4:52 PM

z2bass wrote:
I would just in the SMTP server address... it is probably better that way.

You need to be authenticated, which means you need an email address and password with them.


Hello again. I don't know your first name or i would address you as such. Thanks for all of your replies.

I'm not sure of what you mean by your reply. Are you saying that i should get the ip address of their SMTP server and plug that into 'network host ='?

I will set up an email address with DASP and see if that changes things.

Thanks again.

Tony
Coordinator
Jun 26, 2007 at 5:04 PM
Well, your SMTP address should be something like mail.something.com. Hosters usually give that information in their documentation. Sometimes it is under "setup outlook".

Then you will need to setup an email with your hoster.

Thanks,
Zack
Jun 26, 2007 at 5:24 PM

z2bass wrote:
Well, your SMTP address should be something like mail.something.com. Hosters usually give that information in their documentation. Sometimes it is under "setup outlook".

Then you will need to setup an email with your hoster.

Thanks,
Zack


Hello Zack.

I will contact DASP again. I was already told by their tech support that the SMTP setting should be "<network host="localhost" port="25" . I've also seen that information posted in many of their forum messages, but i will ask them again.

I have already tried setting up a new email address with DASP and tried another test at my website to send out an email. It still gives the same error. I even tried it on two different computers.

Thank,
Tony
Coordinator
Jun 27, 2007 at 1:24 AM
Edited Jun 27, 2007 at 1:24 AM
That just doesn't seem right. Usually hosters give you an absolute SMTP URL and not "localhost". Tell them you want to setup your new email account with outlook and see what the say. I know that requires an absolute SMTP URL.
Jun 27, 2007 at 1:07 PM

z2bass wrote:
That just doesn't seem right. Usually hosters give you an absolute SMTP URL and not "localhost". Tell them you want to setup your new email account with outlook and see what the say. I know that requires an absolute SMTP URL.


Hello Zack.

As i explained in my other post, it was the other email settings.

Although, "<network host="localhost" port="25" " is the correct setting for discountAsp.net.

Thanks,
Tony
Coordinator
Jun 29, 2007 at 4:49 AM
But what SMTP adress do they give if you want to use Outlook?
Jun 30, 2007 at 2:30 AM

z2bass wrote:
But what SMTP adress do they give if you want to use Outlook?


Zack.

According to their documentstion: http://kb.discountasp.net/article.aspx?id=10396, For me in Outlook XP, this would be "smtp.girgenti.info".

Thanks,
Tony
Coordinator
Jun 30, 2007 at 10:34 AM
Alas. That's what you should probably use in your web.config.
Jun 30, 2007 at 2:00 PM

z2bass wrote:
Alas. That's what you should probably use in your web.config.


But Zack. My web site email is working now with "localhost" in it.

Would there be a particular reason to change it?

Thanks,
Tony
Jul 1, 2007 at 2:02 AM
The only reason I would change it is for testing purposes. What I mean is that even when I am running the project on my dev machine, the web.config has the smtp settings for the host account. Then when I send emails from my local machine, I can tell that it is working because it is using the host server.