Can not switch to Design view because of errors in the page

Topics: Help
Jun 27, 2007 at 12:25 PM
Hello.

Without modifying CSK 2.0, i noticed that non-administrators cannot add a new event. Is that the way it is supposed to be.

I noticed that the event link opens the Events\Calendar.aspx, so i attempted to open that page in designer mode using VS2005 Pro. When i did that, i got this error message:
---------------------------
Microsoft Visual Studio
---------------------------
Can not switch to Design view because of errors in the page. Please correct all errors labeled 'Can not switch:' in the Error List and try again.
---------------------------
OK
---------------------------

After i click OK, there are twelve errors in the error list. The first one is this:
"Error 1 Element 'ScriptManager' is not a known element. This can occur if there is a compilation error in the Web site. "

I don't understand how i can build the site without errors, yet opening that page causes those twelve errors.

Any help would be gratefully appreciated.

Thanks,
Tony
Coordinator
Jun 27, 2007 at 2:55 PM
Yea, that is the way it is supposed to be.

That error is caused by ASP.NET AJAX. Do you have that installed on your system?
Jun 27, 2007 at 7:32 PM

z2bass wrote:
Yea, that is the way it is supposed to be.

That error is caused by ASP.NET AJAX. Do you have that installed on your system?


Thanks Zack.

That was it. I downloaded the AJAX stuff and everything and that changed things.

Tony
Coordinator
Jun 27, 2007 at 8:04 PM
Finally... some good news! :-)
Jun 27, 2007 at 8:30 PM

z2bass wrote:
Finally... some good news! :-)


Zack.

I have to apologize. You previously asked me if i changed any of the source code and said no. Well, it turns out that i forgot about the steps i followed to upload this web site to GoDaddy.com. Since then i went to discountAsp.net and never had any problems uploading my website.

The document with the steps i followed from here: http://forums.asp.net/p/970186/1220730.aspx#1220730, showed at step 16 to change all occurences of "dbo." to blank in the source code. I'm sure that has something to do with the databases. I followed those instructions because i thought i was going to use GoDaddy as my hoster.

Later, when i went to discountAsp.net as a hoster, i forgot about those changes and i'm sorry for misinforming you.

I have put all of the "dbo."'s back, uploaded a clean version of the data, reattached it and things seem to be working as they should.

Thanks for all of your help.

Tony
Coordinator
Jun 27, 2007 at 10:35 PM
I am VERY glad to hear that it all worked out!