Connection String

Topics: Help
Oct 8, 2007 at 3:12 PM
I have a folder on my c:\ drive called NBHFC

error from trying to generate DAL classes
Error Message: System.Data.SqlClient.SqlException: An attempt to attach an auto-named database for file C:\NBHF\ClubStarterKit.Web\App_Data\ClubDB.mdf failed. A database with the same name exists, or specified file cannot be opened, or it is located on UNC share

When I try to run the default.aspx, I get "could not find schema information for the element subsonic service"

any help greatly appreciated for this newbie. I had the old one up and running on godaddy and would like to see if I can get this to work on godaddy. After next year, I will switch to a more customer friendly provider

Do you need subsonic to run?

Non profit
Oct 8, 2007 at 3:23 PM
Apoligize for simple grammactical error
NBHFC (needed to add the C)

Will try to upload to godaddy (I will reply)

nonprofit
Coordinator
Oct 8, 2007 at 9:35 PM
In your connection string, you can't use |DataDirectory|. That might cause the error.

Maybe when you are going your generation, do you have the website selected?

You need the SubSonic generated classes... those are necessary for v3 to run.

We can make it work... just keep posting your details on here.
Oct 8, 2007 at 10:25 PM
hello z2bass

Godaddys connection string is below for the first club starter kit that worked. Will the same type of connection string work for V3 R1?

Do I need to paste the updated Database number and regenerate the classes with subsonic before posting to the website. V3 R1 works locally fine with my local path

<connectionStrings>
<add name="ClubSiteDB" providerName="System.Data.SqlClient" connectionString="server=whsql-v19.prod.mesa1.secureserver.net;database=DB_123456;uid=abcdef;pwd=**********"/>
<remove name="LocalSqlServer"/>
<add name="LocalSqlServer" providerName="System.Data.SqlClient" connectionString="server=whsql-v19.prod.mesa1.secureserver.net;database=DB_123456;uid=abcdef;pwd=**********"/>
</connectionStrings>


I know that last clubkit I had to go through about 10 or 12 different replacements with the connection string
Quote from instructions #21 "edit default.aspx" find dbo. replace with <blank>(nothing, nada, zip, zero)

I went to get the latest version and there is another folder called ClubStarterKit.CoreDatabase. Will the schema.sql file need to be updated or can I use the one that was distributed with the blog enhancements. I tried to delete the blogs and still it killed the application.
Coordinator
Oct 9, 2007 at 11:28 PM
Don't use the scripts from ClubStarterKit.CoreDatabase... those won't work.

The Blog fix incorporated works off the same database.

Are you tying to do the generation locally or over the web? It should only work locally.