GoDaddy Setup and Execution

Feb 4, 2008 at 6:20 PM
I have been reading around about setting up the Kit on Godaddy and I know lots of people have issues with this, however I already have a hosting account there with 1 database still free, so I decided to give it a shot.

Initially I set it up by Having GoDaddy create a SQL2005 Database with all the ASP stuff in it already. I suppose this was fine, as the Schema.sql file executed fine on top of that. However, the Data.Sql file didn't execute because of primary key issues. I've decided to recreate it trying to only use the schema and data file and I will see how that goes.

In the first case however, I instantly ran into the security exception issue. I've been googling around and trying to figure out how people are successfully running with this being the case, but I can't seem to find anything. Any help would be great.

Thanks

~Kai

_Description: The application attempted to perform an operation not allowed by the security policy. To grant this application the required permission please contact your system administrator or change the application's trust level in the configuration file.

Exception Details: System.Security.SecurityException: Request for the permission of type 'System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.

Source Error:

Line 599:
Line 600: If Not System.Web.HttpContext.Current Is Nothing Then
Line 601: item.Save(System.Web.HttpContext.Current.User.Identity.Name)
Line 602: Else
Line 603: item.Save(System.Threading.Thread.CurrentPrincipal.Identity.Name)


Source File: d:\hosting\phikai\VINTAGE\App_Code\DAL\Generated\WebSettings.vb Line: 601

Stack Trace:

SecurityException: Request for the permission of type 'System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.
SubSonic.Utilities.Utility.WriteTrace(String message) in Utility.cs:37
SubSonic.AbstractRecord`1.ValidateColumnSettings() in AbstractRecord.cs:901
SubSonic.ActiveRecord`1.Validate() in ActiveRecord.cs:354
SubSonic.ActiveRecord`1.Save(String userName) in ActiveRecord.cs:366
ClubStarterKit.Data.WebSettings.Insert(String varName, String varSlogan, String varCopyright, String varAddress, String varSiteURL, String varMailServer, String varMailUsername, String varMailPassword, Boolean varEmailVerification, Boolean varAdminVerification, Int32 varPageSize, Boolean varReportCMS, String varWebmaster, Boolean varIsHighestWinner, Int32 varModerationLevel, Int32 varCurrentSeason) in d:\hosting\phikai\VINTAGE\App_Code\DAL\Generated\WebSettings.vb:601
ClubStarterKit.Web.Settings.PushToSession() in d:\hosting\phikai\VINTAGE\App_Code\BLL\Settings.vb:31
ASP.globalasax.SessionStart(Object sender, EventArgs e) in d:\hosting\phikai\VINTAGE\global.asax:24
System.Web.SessionState.SessionStateModule.RaiseOnStart(EventArgs e) +2211278
System.Web.SessionState.SessionStateModule.CompleteAcquireState() +154
System.Web.SessionState.SessionStateModule.BeginAcquireState(Object source, EventArgs e, AsyncCallback cb, Object extraData) +547
System.Web.AsyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +90
System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +155_
Feb 4, 2008 at 7:39 PM
It appeared to be an issue with not getting the DATA.SQL script to execute. I just did it and the site is now up, I haven't tested any of the features yet, but at least I have something that is working. Hoepfully this will work out and the small issues will be fine.

~Kai
Feb 4, 2008 at 7:54 PM
Very interesting indeed...I have the site up, however no changes are actually being written.

I tried to create a user and clicked ok, and it didn't do anything. I tried to create a blog, and I get the same security error.

There is obviously something wrong with this medium trust requirement...

What is the best way (aside from a different host) to solve this problem.

Thanks

~Kai
Jan 29, 2009 at 12:55 AM
I am stumbling down the same road... Anyone get this working on GoDaddy?
Jan 29, 2009 at 2:57 PM
If you would like further development of CSK please show your interest here http://forums.asp.net/p/1376917/2898087.aspx. Would you like continued support for your CSK issues let it be known now. Thank you.
Jan 29, 2009 at 4:27 PM
 This is a security issue with subsonic tring to wright to a location that does not trust. here is a link that will help u with that issue but depending on the version or build you are using there are plenty other errors in the code itself. http://forums.subsonicproject.com/forums/p/3226/13362.aspx.
Some suggested reading or I found helpful was http://whswebsite.googlepages.com/.
And here is my work in progress http://www.tcsw.us/

Good luck,
Steven

P.S. I host with Mar-val which I believe uses GoDaddy or is alot the same but if I can help I will.
Feb 14, 2009 at 1:25 AM
Hey  Steven,  I'm trying to get CSK working on GoDaddy,  I've check out your site and I like to know how you got it working..    Check out http://marburyvolleyball.com  try the poll... crashes everytime.  I'll check out the links you provided in your last post.

Thanks,  DJ