Error on live test site

Topics: Help, Request
Feb 28, 2007 at 9:59 AM
Hello,

is there any chance you could tell me how to fix the problem that is now causing your test site for the club starter kit to not function. Its caused by not putting in a description when adding a new news item.

TIA
Trevor
Coordinator
Feb 28, 2007 at 10:13 AM
Yea... go to the DB and delete all the news items. You could also start with a new DB.
Feb 28, 2007 at 10:53 AM
Ok, that gets the system runing again, BUT how can I prevent it from happening in the first place.

TIA
Trevor
Coordinator
Feb 28, 2007 at 7:11 PM
Entering a description for the events :) We will add a validation control for you so you don't forget that it is required ;)
Mar 1, 2007 at 1:19 PM
Ok the site works fine locally, but when I deploy to webhost4life I cannot see the error cause of hte custom tag issue...so I put in that tag to the webconfig and it still did not work, any ideas?

Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".
Coordinator
Mar 1, 2007 at 8:49 PM
Make sure that you can have SQL Express... the issue is caused by some sort of database connectivity problem.
Mar 2, 2007 at 3:09 PM
The runtime error could be anything. Do like the details says and put the custom tag in. That will give you the specific error that you are running into. My site is hosted on webhost4life. Some things I had to do:

1. Strip out all the Ajax stuff.
2. Load the database from the sql2005.sql script in App_Data folder.
Coordinator
Mar 2, 2007 at 7:06 PM
I would check the connection string first... this error is common with database errors.
Mar 5, 2007 at 12:47 PM
The connection string is fine because when I run it from my local dev box the site works perfectly fine. I am using SQL 2005 and when I deploy to webhost4life I get the above error, even with the custom tag in there.
Coordinator
Mar 5, 2007 at 9:15 PM
Your hoster might not support SQL Express, thats probably why.
Mar 5, 2007 at 11:54 PM
I am using SQL 2005 with a correct string? what would still be using sql express?
Coordinator
Mar 6, 2007 at 10:28 AM
Have you checked your trust level. It might have to run in full trust.
Mar 6, 2007 at 11:25 AM
mnebinger could you give me more information on how you got it running? I ran the whole SQL script but can you give me more information on how you stripped out the aJax or could I get your web.config?
Mar 6, 2007 at 7:42 PM
Okay, I will dig it up sometime this evening (the web.config). I have been crazy busy at work lately and haven't been doing much with the clubsite.
Mar 8, 2007 at 2:14 AM
Here is my web.config for webhost4life (with unique info cut out of the connection string and email setup at the bootom):

<?xml version="1.0"?>
<configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
<configSections>
<sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
<sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
<section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
<sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
<section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="Everywhere"/>
<section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
<section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
</sectionGroup>
</sectionGroup>
</sectionGroup>
</configSections>
<appSettings>
<add key="ClubName" value="Pack934"/>
<add key="ClubSlogan" value=""/>
<add key="ClubURL" value="http://www.pack934.com"/>
<add key="FCKeditor:UserFilesPath" value="~/Files/"/>
<add key="FCKeditor:BasePath" value="~/FCKeditor/editor"/>
<!--
Please format the URL like this:
http://www.somesite.com/

**The ends slash is important!
-->
</appSettings>
<location path="admin/ManageUsers.aspx">
<system.web>
<authorization>
<allow roles="Administrators"/>
<deny users="*"/>
</authorization>
</system.web>
</location>
<location path="admin/edituser.aspx">
<system.web>
<authorization>
<allow roles="Administrators"/>
<deny users="*"/>
</authorization>
</system.web>
</location>
<location path="Poll/Manage.aspx">
<system.web>
<authorization>
<allow roles="Administrators"/>
<deny users="*"/>
</authorization>
</system.web>
</location>
<location path="Poll/Answers.aspx">
<system.web>
<authorization>
<allow roles="Administrators"/>
<deny users="*"/>
</authorization>
</system.web>
</location>
<location path="Poll/AddReaction.aspx">
<system.web>
<authorization>
<deny users="?"/>
</authorization>
</system.web>
</location>
<location path="events/edit.aspx">
<system.web>
<authorization>
<allow roles="Administrators"/>
<deny users="*"/>
</authorization>
</system.web>
</location>
<location path="locations/edit.aspx">
<system.web>
<authorization>
<allow roles="Administrators"/>
<deny users="*"/>
</authorization>
</system.web>
</location>
<location path="news/edit.aspx">
<system.web>
<authorization>
<allow roles="Administrators"/>
<deny users="*"/>
</authorization>
</system.web>
</location>
<location path="photo/new.aspx">
<system.web>
<authorization>
<allow roles="Administrators"/>
<deny users="*"/>
</authorization>
</system.web>
</location>
<location path="member/list.aspx">
<system.web>
<authorization>
<deny users="?"/>
</authorization>
</system.web>
</location>
<location path="member/details.aspx">
<system.web>
<authorization>
<deny users="?"/>
</authorization>
</system.web>
</location>
<connectionStrings>
<add name="ClubSiteDB" connectionString="Server=;Database=;Uid=;Pwd=;" providerName="System.Data.SqlClient"/>
</connectionStrings>
<system.web>
<authentication mode="Forms">
<forms loginUrl="member/login.aspx" defaultUrl="~/default.aspx" />
</authentication>
<compilation debug="true" strict="true">
<assemblies>
<add assembly="System.Management, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Configuration.Install, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Data.OracleClient, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Xml, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Messaging, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
</assemblies>
</compilation>
<httpHandlers>
<remove verb="" path=".asmx"/>
<add verb="" path=".asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
<add verb="" path="_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
<add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false"/>
</httpHandlers>
<membership>
<providers>
<remove name="AspNetSqlMembershipProvider"/>
<add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider, &#xA;System.Web, Version=2.0.0.0, Culture=neutral, &#xA;PublicKeyToken=b03f5f7f11d50a3a" connectionStringName="ClubSiteDB" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="true" applicationName="Pack934" requiresUniqueEmail="false" passwordFormat="Hashed" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="4" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" passwordStrengthRegularExpression=""/>
</providers>
</membership>
<profile>
<providers>
<remove name="AspNetSqlProfileProvider"/>
<add name="AspNetSqlProfileProvider" connectionStringName="ClubSiteDB" applicationName="Pack934" type="System.Web.Profile.SqlProfileProvider,&#xA;System.Web, Version=2.0.0.0, Culture=neutral, &#xA;PublicKeyToken=b03f5f7f11d50a3a"/>
</providers>
</profile>
<roleManager enabled="true">
<providers>
<remove name="AspNetSqlRoleProvider"/>
<add connectionStringName="ClubSiteDB" applicationName="Pack934" name="AspNetSqlRoleProvider" type="System.Web.Security.SqlRoleProvider, &#xA;System.Web, Version=2.0.0.0, Culture=neutral, &#xA;PublicKeyToken=b03f5f7f11d50a3a"/>
</providers>
</roleManager>
<siteMap defaultProvider="AspNetXmlSiteMapProvider" enabled="true">
<providers>
<remove name="AspNetXmlSiteMapProvider"/>
<add name="AspNetXmlSiteMapProvider" description="SiteMap provider which reads in .sitemap XML files." type="System.Web.XmlSiteMapProvider" securityTrimmingEnabled="true" siteMapFile="Web.sitemap"/>
</providers>
</siteMap>
<globalization requestEncoding="utf-8" responseEncoding="utf-8"/>
<customErrors mode="Off"/>
</system.web>
<system.webServer>
<validation validateIntegratedModeConfiguration="false"/>
<modules>
<add name="ScriptModule" preCondition="integratedMode" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
</modules>
<handlers>
<remove name="WebServiceHandlerFactory-Integrated"/>
<add name="ScriptHandlerFactory" verb="" path=".asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
<add name="ScriptHandlerFactoryAppServices" verb="" path="_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
<add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
</handlers>
</system.webServer>
<system.net>
<mailSettings>
<smtp from="postmaster@pack934.com">
<network host="mail.pack934.com" userName="" password=""/>
</smtp>
</mailSettings>
</system.net>
</configuration>
Jan 22, 2008 at 4:21 PM
mnebinger -

The astricks screwed up your notes... would you be able to clarify this for my webhost4life account???

<add name="ScriptHandlerFactory" verb="" path=".asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>

I don't see where you made changes specific for wh4l??

I am getting the run time error, and don't know how to change the web.config to show the true error remotely. All I get is:
Server Error in '/' Application
Runtime Error

Thanks for any help!
-Dennis
Jan 22, 2008 at 4:42 PM
Never mind. I just did a cut and paste of your web config, changed the astricks where necessary, and modified the connection string for my server. Thanks!